Pular para conteúdo

hsm codes en US

HSM Return Codes

0 - zero

  • SUCCESS
  • Success return code.
  • Requested function/task/operation succeeded.

5000 - 80001388

  • ERR_UNKNOWN
  • Unknown condition/scenario found.
  • Requested function/task/operation raised an unknown error. This was not supposed to happen.

5001 - 80001389

  • ERR_NET_FAIL
  • Network subsystem failure.
  • Common TCP/IP connection resets or timeouts usually cause this. Other more (rare) scenarios: resource temporarily unavailable; bad address on connect; busy resources; specified host name or IP address is not available from local system; network/host is down; no route to the network/host is available; connection refused.

5002 - 8000138A

  • ERR_ACCESS_DENIED
  • Security subsystem access-denied.
  • HSM denied access cause presented credentials were not enough to fulfill the request. Enabled IP filter and/or user partition 'm of n' smart-card authorization (PnAuth) can also block some operations (check setup on local console).

5003 - 8000138B

  • ERR_CANNOT_CREATE_OBJ
  • Storage layer could not create an object.
  • HSM was not capable of creating an obj (usually a key).

5004 - 8000138C

  • ERR_CANNOT_OPEN_OBJ
  • Storage layer could not open an object.
  • HSM was not capable of opening/using an existing obj (usually a key). Check its id.

5005 - 8000138D

  • ERR_CANNOT_DEL_OBJ
  • Storage layer could not remove an object.
  • HSM was not capable of erasing an obj (usually a key).

5006 - 8000138E

  • ERR_CANNOT_ALLOC_RES
  • Resource could not be allocated.
  • HSM was not capable of allocating/managing/using one or more resources (usually memory).

5007 - 8000138F

  • ERR_INVALID_CTX
  • An invalid operating context was sent in a request.
  • HSM can work with large resources, broken up in chunks. Contexts are employed to manage this state (normally associated with hashes, hmacs, or symmetric keys). An unrecognized context was sent in the request.

5008 - 80001390

  • ERR_INVALID_OPERATION
  • An invalid request was sent/processed.
  • Operations can be flagged as invalid if one or more parameters are not recognized by the HSM, and/or if they are not valid in the operational context.

5009 - 80001391

  • ERR_INVALID_KEY
  • An invalid key was informed.
  • This usually happens when a request is trying to execute an operation with an invalid key type (e.g., using a symmetric key id when doing asymmetric signing tasks), or invalid key id.

5010 - 80001392

  • ERR_NO_TLS_USED
  • Requested operation must be made through encrypted channel.
  • Operations that demand strict confidentiality must be requested using TLS session encryption. For example: a) password changing; b) backup image generation; c) cold-partition operation;

5011 - 80001393

  • ERR_CANNOT_CHANGE_PWD
  • Password change request could not be executed.
  • Happens in 2 scenarios: a) storage layer write failed, or b) shash derivation failed.

5012 - 80001394

  • ERR_OBJ_NOT_EXPORTABLE
  • Obj extraction failure (by means of policy violation).
  • Objects inside the HSM can be saved using a general security policy: a) they're exportable, or b) they're NOT exportable. Keys are usually written in non-exportable mode, while certificates (by their own public nature) can be taken out of the HSM. This error is raised whenever a request is made to retrieve the contents of non-exportable objects.

5013 - 80001395

  • ERR_USR_ALREADY_EXISTS
  • User already exists.
  • The storage and security layers work with partitions to isolate users' data. This error is raised when a create-usr request is made using an existing partition id.

5014 - 80001396

  • ERR_INVALID_USR_NAME
  • Invalid user name informed.
  • Security layer only allows user ids composed of alphanumeric characters (letters or numbers).

5015 - 80001397

  • ERR_CANNOT_CREATE_USR
  • Create user (sub) operation failed.
  • User creations can fail with this code in the following scenario: a) replication live-sync.

5016 - 80001398

  • ERR_NO_MORE_MON_SLOTS
  • There are no more remote monitor resources available.
  • System supports remote monitoring (for users with enough permissions, like sys-operators). But there is a limited number of sessions that can receive live events (currently 7), to avoid system overload.

5017 - 80001399

  • ERR_CANNOT_DELETE_USR
  • User erasing (sub) operation failed.
  • User removals can fail with this code in the following scenarios: a) delete-usr requests ([a.1] when one or more objects from the partition are in use; [a.2] storage layer write failures), or b) replication live-sync.

5018 - 8000139A

  • ERR_CANNOT_DELETE_MASTER
  • Master user erasing operation failed.
  • Master user is special by design. It's the system-operator that comes with the HSM, and can't be removed.

5019 - 8000139B

  • ERR_NOT_IMPLEMENTED
  • Requested functionality is not implemented.
  • No HSM module could execute the requested operation. Please, contact OEM (a firmware update may solve this issue).

5020 - 8000139C

  • ERR_USR_NOT_FOUND
  • User not found.
  • A request was made informing a non-existing user. Please, check its partition id.

5021 - 8000139D

  • ERR_INVALID_PAYLOAD
  • Request sent invalid data.
  • This usually signals invalid informed data (e.g., corrupted files), or invalid parameters.

5022 - 8000139E

  • ERR_OBJ_ALREADY_EXISTS
  • Storage layer could not create object with existing id.
  • Object identification is case-sensitive, and works by partition.

5023 - 8000139F

  • ERR_INVALID_OBJ_NAME
  • Invalid object name informed.
  • Security layer only allows obj ids made of alphanumeric characters (letters or numbers) and '_' (ASCII char 0x5F).

5024 - 800013A0

  • ERR_OBJ_IN_USE
  • Object is in use
  • Request could not be carried further cause informed object is opened.

5025 - 800013A1

  • ERR_CANNOT_WRITE_BACKUP_BLOB
  • Backup image serialization failed.
  • Storage layer could not write backup image to disk. This happens in: a) restore requests, or b) replication live-sync.

5026 - 800013A2

  • ERR_CANNOT_OPEN_BACKUP_BLOB
  • Backup image reading failed.
  • Storage layer could not read backup image from disk. This happens in: a) restore requests, or b) replication live-sync.

5027 - 800013A3

  • ERR_CANNOT_RESTORE_BACKUP_BLOB
  • Backup image final setup failed.
  • Storage layer could setup uploaded backup image. In order to be switched/updated, storage layer must open, process, and setup a backup image, preparing it to be committed later by local console (shell). This error happens in: a) restore requests.

5028 - 800013A4

  • ERR_INVALID_BACKUP_PIN_OR_LEN
  • Backup image validation failed.
  • An invalid backup image may have been sent to server. Usually, the culprit is the PIN informed to decrypt the blob. If it's actually wrong, firmware can't read real data. This happens in: a) restore requests.

5029 - 800013A5

  • ERR_INVALID_XML_SIGNATURE
  • Invalid XML DSig.
  • XML module verified a digital signature according to RFC 3275, and considered it invalid. More info about the standard can be found at ietf.org/rfc/rfc3275.txt.

5030 - 800013A6

  • ERR_INVALID_CERTIFICATE
  • Invalid certificate informed.
  • Raised in the following scenarios: a) PKCS #7 signing ([a.1] when informed X.509 DER certificate can't be loaded and/or decoded; [a.2] certificate and private-key do not match); b) SPB encoding/decoding/mapping/import-cert ([b.1] one of the necessary certs isn't a X.509 DER blob; [b.2] one of the certs isn't a valid Brazil PKI cert; [b.3] certificate PEM is bigger than 10kb); c) User partition certificate security association (SA), when informed X.509 DER can't be loaded and/or decoded;

5031 - 800013A7

  • ERR_VERIFY_XML_FAILED
  • XML DSig verification failure.
  • XML module tried to verify a digital signature according to RFC 3275, but runtime errors occurred, preventing a more detailed diagnostic (such as mem-alloc-errors, IO-issues, xml-template-problems, not-found-cert, cert-expiration, revoked-cert, unknown-cert-issuer, cert-not-valid-yet, cert-store-errors, etc).

5032 - 800013A8

  • ERR_INVALID_XML
  • XML DSig signing or verification failed.
  • XML module tried to generate or verify a digital signature according to RFC 3275, but was not able to handle the informed XML (it's probably malformed/invalid).

5033 - 800013A9

  • ERR_SIGN_XML_FAILED
  • XML DSig generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but runtime errors occurred, preventing a more detailed diagnostic (such as mem-alloc-errors, IO-issues, xml-template-problems, not-found-cert, cert-expiration, revoked-cert, unknown-cert-issuer, cert-not-valid-yet, cert-store-errors, etc).

5034 - 800013AA

  • ERR_UPACK_VERIFY_FAILED
  • Update-package signature check failed.
  • Firmware updates can be made through update-packages (upacks) uploading. In order to prevent malicious inputs, and/or corrupted data to reach firmware runtime layer, upacks have their content signed by OEM, and their signatures validated when submitted to the HSM.

5035 - 800013AB

  • ERR_CANNOT_TRUNCATE_LOG
  • Log truncation failed.
  • Server log has a maximum size of ~4GB, but it can be truncated to free system resources. This error usually signals storage layer IO problems: server may be under extreme loads, and/or physical disk problems are preventing the operation to take place. Please, try again in a few moments. If the error persists, it's advisable to reboot the HSM. Even after that, if the log still can not be truncated, contact OEM for further instructions.

5036 - 800013AC

  • ERR_CANNOT_BACKUP_OLD_LOG
  • Log backup generation failed.
  • Atomic log truncation may involve the use of internal backup copies. In practice this code is rarely used, and has been deprecated by newer firmware versions.

5037 - 800013AD

  • ERR_CERTIFICATE_EXPIRED
  • Expired certificate informed.
  • Certificate is considered expired against current HSM date/time. Raised in the following scenarios: a) SPB encoding/decoding/mapping/import-cert; b) CRL validation; c) XML DSig signing/verification according to RFC 3275;

5038 - 800013AE

  • ERR_CERTIFICATE_FAILED
  • Certificate handling failed.
  • Given an operational context - like when parsing/using cert content - an error occurred, preventing a more detailed diagnostic (such as mem-alloc-errors, IO-issues, cert-store-errors, etc). Raised in: a) SPB decode requests (usually associated to GEN msgs that demand auto-update operations); b) SPB import-cert; c) XML DSig signing/verification according to RFC 3275;

5039 - 800013AF

  • ERR_CERTIFICATE_NOT_FOUND
  • Certificate not found.
  • XML DSig signing/verification according to RFC 3275 could not be executed cause storage layer was not able to track and open the cert (also happens when cert can't be extracted from PKCS #7 messages/containers).

5040 - 800013B0

  • ERR_CERTIFICATE_REVOKED
  • Informed certificated is revoked.
  • Raised in the following scenarios: a) CRL validation; b) XML DSig signing/verification according to RFC 3275;

5041 - 800013B1

  • ERR_CERTIFICATE_ISSUER_FAILED
  • Unknown certificate issuer found.
  • XML module tried to generate or validate a digital signature according to RFC 3275, but one or more certs in the chain could not be identified as trusted.

5042 - 800013B2

  • ERR_CERTIFICATE_NOT_YET_VALID
  • Certificate not valid yet.
  • For current HSM date/time, certificate is not valid yet. Raised in the following scenarios: a) CRL validation; b) XML DSig signing/verification according to RFC 3275;

5043 - 800013B3

  • ERR_CERT_EXPIRED_SIGN_VALID
  • A valid XML DSig was found, but using an expired certificate.
  • XML DSig verification according to RFC 3275 succeeded, but the cert used in the process is already expired (i.e., a "dated verify" was made; signature was valid at generation time, and is still correct, if certificate expiration against current HSM date/time is disregarded).

5044 - 800013B4

  • ERR_CRL_EXPIRED
  • Certificate Revocation List (CRL) is expired.
  • CRL validation failed (it's considered expired against current HSM date/time).

5045 - 800013B5

  • ERR_INVALID_CRL_SIGN
  • Certificate Revocation List (CRL) invalid signature.
  • CRL signature verification failed (see RFC 2459).

5046 - 800013B6

  • ERR_CRL_CERT_MISMATCH
  • Certificate Revocation List (CRL) issuer mismatch.
  • CRL validation failed (its issuer and informed issuer certificate don't match).

5047 - 800013B7

  • ERR_CERT_REVOKED_LIBCLIENT_FIX1
  • Informed certificated is revoked.
  • See ERR_CERT_REVOKED.

5048 - 800013B8

  • ERR_ACCESS_DENIED_TOKEN_NOT_NEEDED
  • Security subsystem access-denied.
  • HSM denied access cause presented credentials include invalid authentication factors (like a token OTP, when user is not configured to use it).

5049 - 800013B9

  • ERR_ACCESS_DENIED_TOKEN_NEEDED
  • Security subsystem access-denied.
  • HSM denied access cause presented credentials must include extra authentication factors (like a token OTP).

5050 - 800013BA

  • ERR_CERT_REVOKED_CRL_VAL_UNUSED
  • Informed certificated is revoked.
  • CRL validation was made without verifying CRL (i.e., cert is included in CRL, but CRL signature verification was not done).

5051 - 800013BB

  • ERR_CERT_VALID_CRL_VAL_UNUSED
  • Informed certificated is not revoked.
  • CRL validation was made without verifying CRL (i.e., cert is not included in CRL, but CRL signature verification was not done).

5052 - 800013BC

  • ERR_CANNOT_PARSE_XML
  • XML parsing error.
  • HSM was not able to decode the informed XML (it's probably malformed/invalid). Raised in the following scenarios: a) XML DSig signing/verification according to RFC 3275; b) OATH module PSKC importing;

5053 - 800013BD

  • ERR_CANNOT_CREATE_XML_SIG_TEMPL
  • XML DSig template generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but XML manipulation errors occurred, and prevented the template building. A more detailed tag problem diagnostic (such as mem-alloc-errors) was not possible.

5054 - 800013BE

  • ERR_CANNOT_ADD_XML_SIG_TEMPL_REF
  • XML DSig template generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but XML <dsig:Signature/> node manipulation error occurred, and prevented the addition. A more specific tag problem diagnostic (such as mem-alloc-errors) is not available.

5055 - 800013BF

  • ERR_CANNOT_ADD_XML_SIG_TEMPL_TRANS
  • XML DSig template generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but XML enveloped and/or C14N transform errors occurred, and prevented the setup. A more specific diagnostic (such as mem-alloc-errors) is not available.

5056 - 800013C0

  • ERR_CANNOT_ADD_XML_SIG_KEY_INFO
  • XML DSig template generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but XML <dsig:KeyInfo/> node manipulation error occurred, and prevented the addition. A more specific tag problem diagnostic (such as mem-alloc-errors) is not available.

5057 - 800013C1

  • ERR_CANNOT_ADD_XML_SIG_KEY_CERT
  • XML DSig template generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but XML <dsig:X509Data/> node manipulation error occurred, and prevented the addition. A more specific tag problem diagnostic (such as mem-alloc-errors) is not available.

5058 - 800013C2

  • ERR_CANNOT_ALLOC_XML_SIG_CTX
  • XML DSig signing or verification failed.
  • XML module tried to generate or verify a digital signature according to RFC 3275, but was not able to allocate an internal context structure (probably a memory allocation failure).

5059 - 800013C3

  • ERR_CANNOT_PARSE_DER_PRIV_KEY
  • XML DSig signing failed.
  • XML module tried to generate a digital signature according to RFC 3275, but was not able to recover the corresponding private-key. It's usually a memory allocation problem when doing DER decoding. In extreme cases, it may signal data corruption.

5060 - 800013C4

  • ERR_XML_CANNOT_LOAD_PRIV_KEY
  • XML DSig signing failed.
  • XML module tried to generate a digital signature according to RFC 3275, but was not able to recover the corresponding private-key. It's usually a memory allocation problem when doing DER decoding. In extreme cases, it may signal data corruption.

5061 - 800013C5

  • ERR_XML_CANNOT_LOAD_CERT
  • XML DSig signing failed.
  • XML module tried to generate a digital signature according to RFC 3275, but was not able to recover the corresponding certificate. It's usually a memory allocation problem when doing DER decoding. In extreme cases, it may signal data corruption.

5062 - 800013C6

  • ERR_XML_CANNOT_CREATE_KEY_MNG
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to allocate an internal key structure (probably a memory allocation failure).

5063 - 800013C7

  • ERR_XML_CANNOT_INIT_KEY_MNG
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to manipulate an internal key structure (probably a memory allocation failure).

5064 - 800013C8

  • ERR_XML_CANNOT_LOAD_TRUSTED_CERTS
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to recover the corresponding certificate chain. It's usually a memory allocation problem when doing DER decoding. In extreme cases, it may signal data corruption.

5065 - 800013C9

  • ERR_XML_SIG_NODE_NOT_FOUND
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to find <dsig:Signature/> node (XML is probably malformed/invalid).

5066 - 800013CA

  • ERR_XML_CERT_NODE_NOT_FOUND
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to find <dsig:X509Data/> node (XML is probably malformed/invalid).

5067 - 800013CB

  • ERR_XML_CANNOT_DECODE_CERT_NODE
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to decode <dsig:X509Data/> node data into a valid X.509 DER blob (XML can be malformed/invalid, and/or mem-alloc problems were encountered).

5068 - 800013CC

  • ERR_CANNOT_PARSE_DER_CERT
  • XML DSig verification failed.
  • XML module tried to verify a digital signature according to RFC 3275, but was not able to decode <dsig:X509Data/> X.509 DER cert (XML can be malformed/invalid, and/or mem-alloc problems were encountered).

5069 - 800013CD

  • ERR_DEPRECATED_XML_COMPRESS
  • XML DSig failure.
  • XML module could not parse input to generate/verify RFC 3275 digital signatures. Module worked with RFC 1950 (ZLIB), RFC 1951 (DEFLATE), and RFC 1952 (GZIP) standards, but this was removed/deprecated. Newer firmwares will return ERR_CANNOT_PARSE_XML.

5070 - 800013CE

  • ERR_INVALID_CERTIFICATE_NULL_RES
  • Certificate handling failed.
  • Given an operational context - like when parsing/using cert content - an error occurred, that prevented a more detailed diagnostic (such as mem-alloc-errors, IO-issues, cert-store-errors, etc). Raised in: a) SPB encoding/decoding/mapping requests (e.g., when decoding GEN msgs that demand auto-update operations); b) XML module signature generation according to RFC 3275; c) PKCS #12 file imports;

5071 - 800013CF

  • ERR_CANNOT_RECREATE_MASTER
  • Master user creation forbidden.
  • The storage and security layers work with partitions to isolate users' data. This error is raised when a create-usr request is made using master partition id (master user is special by design; it's the sys-operator that comes with the HSM, and can't be [re]created or removed).

5072 - 800013D0

  • ERR_CANNOT_CREATE_USR_STORAGE1
  • Create user transportation failed.
  • Raised when a create-usr operation was accepted and distributed by replication layer, but failed to be transported/saved to storage layer. This code is transient by nature. If it persists, please contact OEM.

5073 - 800013D1

  • ERR_CANNOT_CREATE_USR_STORAGE2
  • User creation/erasing transportation failed.
  • DEPRECATED. Raised by old firmware versions when create/delete-usr operations were accepted and distributed by replication layer, but failed to be transported/saved to storage layer. This code is transient by nature. If it persists, please contact OEM.

5074 - 800013D2

  • ERR_CANNOT_CREATE_USR_DEFAULT_ACL
  • Create user transportation failed.
  • Raised when: a) create-usr operation was accepted and distributed by replication layer, but was not transported/saved to storage layer, cause user default access control list (ACL) serialization failed. In this situation, the code is transient by nature (if it persists, please contact OEM); b) replication live-sync fails to serialize access control lists; the error is synchronous in this scenario;

5075 - 800013D3

  • ERR_CANNOT_ALLOC_CTX
  • An operating context could not be allocated.
  • HSM can work with large resources, broken up in chunks. Contexts are employed to manage this state, normally associated with hashes, hmacs, or symmetric keys (but not limited to them). E.g., SPB decode operations may fail with this code when handling compressed messages. Another (rare) situation where this error is raised is when DRBG subsystem can't generate random numbers. Usually, context allocation failures happen when no more free memory is available to process some resource.

5076 - 800013D4

  • ERR_CANNOT_LOAD_PRIV_KEY
  • Private-key loading/using failure.
  • Private-keys are used in asymmetric cryptography to perform digital signatures or enveloped symmetric key recovery. An operation tried to retrieve an existing private RSA/ ECC key, but was not able to access/decode its DER representation. Memory allocation problems are usually at the heart of these issues; in extreme cases, some kind of data corruption may be involved. It may be raised in: a) core RSA/ECC tasks; b) ISO 9796 signature generation; c) PKCS #8 exports/imports; d) SPB decoding requests (e.g., when decoding GEN msgs that demand auto-update operations);

5077 - 800013D5

  • ERR_CANNOT_DECODE_PUB_KEY
  • Public-key loading/using failure.
  • Public-keys are used in asymmetric cryptography to verify digital signatures or envelop symmetric keys. An operation tried to retrieve a public RSA/ ECC key, but was not able to process its DER representation. Memory allocation problems are usually at the heart of these issues; in extreme cases, some kind of data corruption may be involved. It may be raised in: a) core RSA/ECC tasks;

5078 - 800013D6

  • ERR_CANNOT_GENERATE_RND_DATA
  • Random number generation error.
  • HSM could not generate a stream of cryptographically strong random numbers. The (rare) root cause for this error is DRBG subsystem impossibility to work (usually related to memory allocation problems). Raised in some scenarios: a) user authentication; b) explicit random number generation requests; c) OATH module blob issuing; d) whenever replication layer needs to synchronize state between HSMs/nodes in a pool;

5079 - 800013D7

  • ERR_CACHE_LAYER_EXHAUSTED
  • Storage layer could not open an object.
  • HSM works with many cache layers to optimize storage usage. It was not capable of opening an existing obj (usually a key), cause, in order to deliver an outstanding performance, there's a limited amount of memory reserved for caching. In practice this code normally signals a large number of objs opened at the same time. Please, check pending connections (they can be locking temporary objs), and/or objs that are no longer necessary for regular operation.

5080 - 800013D8

  • ERR_RSA_POWER_SIGN_FAILED
  • Optimized signature generation failure.
  • Core module tried to generate a digital signature according to PKCS #1, but runtime errors occurred, that prevented a more detailed diagnostic (such as mem-alloc-errors, etc).

5081 - 800013D9

  • ERR_CANNOT_DEMOTE_MASTER
  • Master user demoting forbidden.
  • Master user is special by design; it's the sys-operator that comes with the HSM, and can't have its permissions changed.

5100 - 800013EC

  • ERR_CANNOT_GET_SYS_INFO
  • System information retrieval failure.
  • State manager module could not retrieve important system information to deliver runtime status data to client. In very rare scenarios (e.g., legacy firmware versions), this may signal DRBG subsystem inability to get system date/time counters (essential to its diversification implementation).

5101 - 800013ED

  • ERR_CANNOT_ALLOC_UPACK_ID
  • Update-package upload failure.
  • Firmware updates can be made through update-packages (upacks) uploading. State manager module was not able to receive one such upack, cause its internal id generation failed. DRBG subsystem malfunctioning/errors can cause this (see ERR_CANNOT_GENERATE_RND_DATA for more details).

5102 - 800013EE

  • ERR_CANNOT_ALLOC_UPACK_PATH
  • Update-package upload failure.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_ALLOC_UPACK_ID.

5103 - 800013EF

  • ERR_CANNOT_WRITE_UPACK_OBJ
  • Update-package upload failure.
  • Firmware updates can be made through update-packages (upacks) uploading. State manager module was not able to receive such upack, cause its writing to storage layer failed.

5104 - 800013F0

  • ERR_INVALID_CRL
  • Certificate Revocation List (CRL) loading/using failure.
  • Certificate revocation lists are used in PKIs to store certificate serial numbers that have been revoked (therefore, should no longer be trusted). An operation tried to retrieve a CRL, but was not able to access/decode its DER representation. Memory allocation problems are usually at the heart of these issues; in extreme cases, some kind of data corruption may be involved.

5105 - 800013F1

  • ERR_OPERATION_FAILED
  • Requested function/task/operation failed.
  • Requested function/task/operation raised this generic - sometimes legacy code - to signal that an internal problematic condition was found. Can happen in a wide class of scenarios (e.g., crypto/mathematical manipulations, mem-allocs, IO, etc). Newer firmware versions have more specialized codes, that make tracking these situations easier.

5106 - 800013F2

  • ERR_GET_USR_ACL_FAILED
  • Security subsystem could not retrieve user permissions.
  • Security subsystem could not get user access control list (ACL) holding its permissions. It's usually a transient problem, caused by system overload. Please, check user id, and try again later.

5107 - 800013F3

  • ERR_INVALID_SIGNATURE
  • Invalid signature.
  • HSM found an invalid signature/code while doing RSA/ECC/EdDSA/MAC verification or AEAD/XML/SPB/PIX operations.

5108 - 800013F4

  • ERR_CANNOT_GENERATE_SOFT_TOKEN
  • HOTP soft-token issuing failure.
  • DEPRECATED. Raised by old firmware versions when automatic HOTP JavaME app issuing failed. NOTE: mod_OTP functionality is no longer available; it's considered insecure if modern security practices are taken into account.

5109 - 800013F5

  • ERR_INVALID_SECRET
  • Invalid security parameter presented.
  • Critical security parameters (CSPs) can take the form of crypto keys, passwords, one-time-passwords (OTPs), PINs, 'm of n' shadows, etc. One such parameter was sent in a request to process some operation, and it was not considered valid. EFT/ EMV and OATH modules can raise this error.

5120 - 80001400

  • ERR_ACCESS_DENIED_USR_BLOCKED
  • Security subsystem access-denied and user blocked.
  • HSM denied access cause presented credentials were not enough to fulfill the request. User was also blocked (disabled), cause global security policy is active.

5121 - 80001401

  • ERR_INVALID_IMEI
  • HOTP soft-token issuing failure.
  • DEPRECATED. Raised by old firmware versions when automatic HOTP JavaME app issuing failed (invalid IMEI was submitted). NOTE: mod_OTP functionality is no longer available; it's considered insecure if modern security practices are taken into account.

5122 - 80001402

  • ERR_REPLAY_DETECTED
  • One Time Password (OTP) replay detected.
  • OATH module detected an OTP reutilization attempt, and raised this exception. Can happen to both HOTP and TOTP otp types.

5123 - 80001403

  • ERR_NON_APPROVED_OPERATION
  • Non approved operation refused.
  • A functionality was requested while HSM is operating in restricted mode (e.g., MC7 or FIPS). Only specific cryptographic algorithms/protocols/standards are allowed (i.e., weak/legacy crypto like MD5 and ARC4 is disallowed). It's invalid to restore backup images generated in standard mode when restricted mode is active (firmware updates are also disabled).

5124 - 80001404

  • ERR_ACCESS_DENIED_OBJ_BLOCKED
  • Security subsystem denied access to blocked object.
  • HSM denied opening/using an existing obj (usually a key), cause it's disabled, or violated some SP 800-57 policy (in this case, check HSM date/time first). Obj owner (or other authorized user) may unblock it.

5125 - 80001405

  • ERR_DRBG_CONTINUOUS_TEST
  • Random number generation error.
  • HSM detected a security problem while doing a runtime test, and refused to generate a stream of cryptographically strong random numbers. See ERR_CANNOT_GENERATE_RND_DATA for extra context details that may apply here.

5126 - 80001406

  • ERR_RSA_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5127 - 80001407

  • ERR_ECC_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5128 - 80001408

  • ERR_DES_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5129 - 80001409

  • ERR_AES_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5130 - 8000140A

  • ERR_ALT_BN128_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5175 - 80001437

  • ERR_CANNOT_UPDATE_OBJ
  • Storage layer could not update an object.
  • HSM was not capable of updating an obj (usually key related data, but can also be raised when [a] updating map info, [b] {un}blocking objs, and [c] doing replication live-syncs).

5176 - 80001438

  • ERR_CANNOT_GET_PWD_POLICY
  • Critical Password Security Parameter retrieval failure.
  • Storage layer could not read a password CSP (its shash, expiration policy, and/or global length/formation policy). This error is transient by nature. If it persists, please contact OEM.

5177 - 80001439

  • ERR_PWD_BLOCKED_BY_POLICY
  • Password length/formation error.
  • Security layer blocked password changes or user creation cause global length/formation policy was violated.

5178 - 8000143A

  • ERR_PWD_EXPIRED
  • Password change requested, or a-token is expired.
  • It may be raised in: a) Global password expiration policy is active. Security layer authenticated user credentials, but requested a password change for current session unlocking (other operations will be blocked meanwhile); b) Access/Authentication token is expired, and can no longer impersonate user;

5179 - 8000143B

  • ERR_CERT_VALID_CRL_VAL_UNUSED_CRL_EXPIRED
  • Informed certificate is not revoked.
  • Certificate check was made against an expired CRL (current HSM date/time is the reference). I.e., cert is not included in CRL. No CRL or cert signature verification was done.

5180 - 8000143C

  • ERR_CERT_VALID_CRL_EXPIRED
  • Informed certificate is not revoked.
  • Certificate check was made against an expired CRL (current HSM date/time is the reference). I.e., cert is not included in CRL. CRL and cert signature verification was done.

5181 - 8000143D

  • ERR_INVALID_CERT_SIGN
  • Informed certificate is invalid.
  • Certificate CRL check detected an invalid cert signature.

5200 - 80001450

  • ERR_CANNOT_LOAD_CORRUPTED_OBJ
  • Storage layer could not manipulate an object.
  • HSM could not open/export/rename an existing obj (usually a key), cause its data integrity verification failed. Firmware employs a SHA1 checksum (with 160-bits). This error can be transient, but usually signals severe data corruption (and/or hardware problems). Consult OEM.

5230 - 8000146E

  • ERR_INVALID_CERT_ISPB_MISMATCH
  • Certificate mismatch error.
  • An attempt to use SPB module encode/decode/mapping detected a mismatch between informed source/destiny ISPB, and the internal ISPB that comes with used certificate.

5231 - 8000146F

  • ERR_INVALID_CA
  • Invalid Certificate Authority (CA).
  • SPB module decode (usually associated to GEN msgs that demand auto-update operations) or encode requests tried to use a certificate issued from an unknown CA. Following CAs/values are recognized from SPB manual, section 4.2.6: a) Serpro (1); b) Certisign (2); c) Serasa (4); d) CAIXA (5); e) Valid (6);

5232 - 80001470

  • ERR_OPERATION_BLOCKED_BY_SEPOL
  • Security subsystem blocked operation violating global policy.
  • HSM blocked an operation which violates one or more global security policies.

5303 - 800014B7

  • ERR_DEPRECATED_FUNCTION
  • A deprecated function/task/operation request failed.
  • OEM is permanently improving its products. A legacy feature is no longer available, cause modern security best practices probably consider its execution a threat (even if once this was valid/appropriate).

5304 - 800014B8

  • ERR_SERVER_BUSY
  • Server is overloaded.
  • DEPRECATED. Raised by old firmware versions when requests were refused. Used to signal server overloading. More specific errors are employed by new firmware versions instead, improving customer infrastructure troubleshooting. In any case, this is usually a transient problem. Please, try again later.

5305 - 800014B9

  • ERR_SL_BE_BUSY
  • Storage layer reading failure.
  • A request could not be executed cause storage layer is overloaded by too many IO operations. It's more common in obj listing. This is usually a transient problem. Please, try again later.

5306 - 800014BA

  • ERR_SVMK_MISMATCH
  • Server Master Key (SVMK) backup image mismatch.
  • A backup restore was attempted, but image was originally generated in a HSM loaded with a different SVMK (compared to current one). In this scenario, restore will always fail, protecting customer base against data loss.

5307 - 800014BB

  • ERR_INVALID_CERT_SN_MISMATCH
  • Certificate mismatch error.
  • SPB module encode/decode request detected a mismatch between informed certificate serial number (SN), and SN that comes within SPB message header. This double-check protects customer against data corruption and/or malformed (invalid/inconsistent) messages.

5308 - 800014BC

  • ERR_CANNOT_DEC_SYM_KEY
  • Symmetric key could not be decrypted.
  • SPB module decode error. SPB messages carry a digital envelope to protect confidential data. When target receives a message, its digital envelope must be opened, so the 3DES key that protects original content can be recovered. To do this, receiver uses its private-key. If sender employed an incorrect public-key to setup the envelope, and/or message is somehow corrupted, the envelope won't be properly undone, and this error is raised.

5309 - 800014BD

  • ERR_CANNOT_REC_SYM_KEY
  • Symmetric key could not be recovered/rescheduled.
  • SPB module decode error. 3DES key envelop was correctly decrypted, but its crypto scheduling failed. This is usually a memory allocation issue. See ERR_CANNOT_DEC_SYM_KEY for extra details.

5401 - 80001519

  • SUCCESS_CANNOT_OPEN_OBJ_AT_REPL
  • Storage layer could not open an object.
  • HSM was not capable of opening/using an obj created successfully (usually a key), cause it's still being written by replication layer. In a few moments this obj will probably be available for regular use.

5402 - 8000151A

  • ERR_CANNOT_OPEN_INVALID_OBJ_AT_REPL
  • Storage layer could not open an object.
  • HSM was not capable of opening/using an obj that has changed (was [un]blocked, deleted, or renamed), caused it's still being updated by replication layer. In a few moments, obj final status will probably be available.

5500 - 8000157C

  • ERR_CANNOT_SL_BE_CHECK_OBJ
  • Storage layer could not create an object.
  • HSM was not capable of creating an obj (usually a key), because event validation low-level IO failed. This is a rare issue (usually transient). Please, try again later.

5501 - 8000157D

  • ERR_CANNOT_WRITE_AUTH_INFO_OBJ
  • Storage layer could not write authentication data.
  • HSM was not capable of writing user OATH information. This is a low level rare problem (usually transient). Please, try again later.

5502 - 8000157E

  • ERR_CANNOT_GEN_RSA_KEY
  • Storage layer could not create an RSA key.
  • HSM could not create an RSA key cause its crypto material handling failed. This can be a memory allocation issue. In rare scenarios, random number generation may have failed. See ERR_DRBG_CONTINUOUS_TEST for extra details that may apply here. If this error persists, please contact OEM.

5503 - 8000157F

  • ERR_CANNOT_GEN_ECC_CURVE
  • Storage layer could not create an ECC key.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_GEN_ECC_KEY.

5504 - 80001580

  • ERR_CANNOT_GEN_ECC_KEY
  • Storage layer could not create an ECC key.
  • HSM could not create an ECC key cause its crypto material handling failed. This can be a memory allocation issue. In rare scenarios, random number generation may have failed. See ERR_DRBG_CONTINUOUS_TEST for extra details that may apply here. If this error persists, please contact OEM.

5505 - 80001581

  • ERR_CANNOT_GEN_ECC_DER
  • Key serialization error.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_ALLOC_MEM.

5506 - 80001582

  • ERR_CANNOT_GEN_ECC_DER_KEY
  • Key serialization error.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_ALLOC_MEM.

5507 - 80001583

  • ERR_CANNOT_CREATE_UNKNOWN_OBJ
  • Storage layer could not create unrecognized obj.
  • HSM could not create an obj (usually a key), cause it's unrecognized. Please, contact OEM (a firmware update may solve this issue).

5508 - 80001584

  • ERR_CANNOT_WRITE_HSM_MODE
  • Storage layer could not change HSM mode.
  • HSM was not capable of updating operation mode, cause an IO error occurred. This is a low level rare problem (usually transient). Please, try again later.

5509 - 80001585

  • ERR_CANNOT_WRITE_LOGIN_BLOCK_INFO
  • Security layer could not write login [un]blocking data.
  • HSM was not capable of writing user login [un]blocking information. This is a low level rare problem (usually transient). Please, try again later.

5510 - 80001586

  • ERR_CANNOT_SETUP_LIVE_SYNC_OBJ
  • Storage layer could not setup object data writing.
  • HSM could not write obj data when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5511 - 80001587

  • ERR_CANNOT_CREATE_LIVE_SYNC_OBJ
  • Storage layer could not write object data.
  • HSM was not capable of writing obj data when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5512 - 80001588

  • ERR_CANNOT_OPEN_LOG
  • Storage layer could not open audit log.
  • HSM could not open log file. This is a rare low-level IO issue. If this error persists, please contact OEM.

5513 - 80001589

  • ERR_COULD_NOT_OPEN_OBJ
  • Storage layer could not create a local/temporary object.
  • HSM was not capable of opening/using an obj (usually a key) that was about to be created (otherwise, it would successfully be saved). See ERR_CANNOT_OPEN_OBJ, ERR_CANNOT_ALLOC_RES and ERR_CACHE_LAYER_EXHAUSTED for extra details that may apply here. If this error persists, please contact OEM.

5514 - 8000158A

  • ERR_CANNOT_EXPORT_RAW_OBJ
  • Obj extraction failure (by means of IO failure).
  • Objects inside the HSM can be saved using a general security policy: a) they're exportable, or b) they're NOT exportable. Keys are usually written in non-exportable mode, while certificates (by their own public nature) can be taken out of the HSM. This error is raised whenever a request is made to retrieve the full content of exportable objects, but low-level IO failed.

5515 - 8000158B

  • ERR_CANNOT_RENAME_OBJ
  • Storage layer could not rename an object.
  • HSM was not capable of renaming an existing obj (usually a key). Cross renames are not allowed by design (when one user tries to move/rename an obj from another partition, even if original owner has given write/update permissions). Users can only rename theirs own objs.

5516 - 8000158C

  • ERR_REPLICATION_CANNOT_OPEN_OBJ
  • Replication layer could not open an object.
  • HSM could not open/use an existing obj (usually a key). See ERR_CANNOT_OPEN_OBJ details.

5517 - 8000158D

  • ERR_CANNOT_SETUP_LIVE_SYNC_IMG
  • Replication layer could not setup live-sync image.
  • HSM could not setup replication live-sync data image. This is usually a memory allocation issue. Please, try again later.

5518 - 8000158E

  • ERR_CANNOT_LOAD_LIVE_SYNC_IMG
  • Replication layer could not read live-sync image.
  • HSM could not read replication live-sync data image. This is a low-level IO problem (very rare). Please, try again later.

5519 - 8000158F

  • ERR_CANNOT_SETUP_LIVE_SYNC_DEL_USR
  • Replication layer could not setup user removal.
  • HSM could not remove user data when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5520 - 80001590

  • ERR_CANNOT_DEL_LIVE_SYNC_USR
  • Replication layer could not remove user(s).
  • HSM was not capable of removing user data when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5521 - 80001591

  • ERR_CANNOT_SETUP_LIVE_SYNC_DEL_CONFIG
  • Replication layer could not setup config removal.
  • HSM could not remove config data when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5522 - 80001592

  • ERR_CANNOT_DEL_LIVE_SYNC_CONFIG
  • Replication layer could remove config.
  • HSM was not capable of removing config data when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5523 - 80001593

  • ERR_CANNOT_SETUP_LIVE_SYNC_CONFIG
  • Replication layer could not setup new config.
  • HSM could not add new config data when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5524 - 80001594

  • ERR_CANNOT_CREATE_LIVE_SYNC_CONFIG
  • Replication layer could add new config.
  • HSM was not capable of adding new config data when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5525 - 80001595

  • ERR_CANNOT_SETUP_LIVE_SYNC_USER
  • Replication layer could not setup new user(s).
  • HSM could not add new user(s) data when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5526 - 80001596

  • ERR_CANNOT_CREATE_LIVE_SYNC_USER
  • Replication layer could add new user(s).
  • HSM was not capable of adding new user data when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5527 - 80001597

  • ERR_CANNOT_SETUP_LIVE_SYNC_ACL
  • Replication layer could not setup user permissions.
  • HSM could not add new access control lists (ACL) holding users' permissions when doing a replication live-sync. This is usually a memory allocation issue. Please, try again later.

5528 - 80001598

  • ERR_CANNOT_CREATE_LIVE_SYNC_ACL
  • Replication layer could add user permissions.
  • HSM was not capable of adding users' permissions when doing a replication live-sync. This is a low-level IO problem (very rare). Please, try again later.

5529 - 80001599

  • ERR_CANNOT_DEL_AUTH_INFO_OBJ
  • Storage layer could not remove authentication data.
  • HSM was not capable of erasing user OATH information. This is a low level rare problem (usually transient). Please, try again later.

5530 - 8000159A

  • ERR_INVALID_KEY_NULL_RES
  • Key handling failed.
  • Given an operational context - like when parsing/using key content - an error occurred, that prevented a more detailed diagnostic (such as mem-alloc-errors, IO-issues, storage-errors, etc). Raised in: a) SPB encoding/decoding/mapping requests (e.g., when decoding GEN msgs that demand auto-update operations); b) XML module signature generation according to RFC 3275;

5531 - 8000159B

  • ERR_INVALID_MSG_NULL_RES
  • Msg handling failed.
  • Given an operational context - like when creating/using message content - an error occurred, that prevented a more detailed diagnostic (such as mem-alloc-errors). Raised in: a) PKCS #7 signing (when msg DER can't be loaded/encoded);

5532 - 8000159C

  • ERR_CANNOT_GEN_SYM_KEY
  • Symmetric key could not be manipulated.
  • Symmetric keys are usually employed in operations that involve data confidentiality (but are not limited to them). Their proper allocation/scheduling needs memory and cryptographically strong random numbers. If any intermediate generation/setup step fails, given key can't be used. See ERR_CANNOT_GENERATE_RND_DATA and ERR_DRBG_CONTINUOUS_TEST for extra details. It may be raised in: a) SPB encoding requests; SPB messages carry a digital envelope to protect confidential data; this error is raised if sender can't setup 3DES or AES envelope keys;

5533 - 8000159D

  • ERR_CANNOT_SETUP_USR_AUTH_INFO
  • Storage layer could not setup user authentication.
  • HSM could not retrieve user authentication information. This is usually a memory allocation issue. Please, try again later.

5534 - 8000159E

  • ERR_CANNOT_BIND_USR_AUTH_INFO
  • Storage layer could not setup user authentication.
  • HSM could not retrieve user authentication information. This is usually a memory allocation issue. Please, try again later.

5535 - 8000159F

  • ERR_CANNOT_GET_CERT_SN
  • Certificate serial number read error.
  • SPB module encode or decode (the latter, when decoding GEN msgs that demand auto-update operations) could not retrieve certificate serial number (SN). It's usually a memory allocation problem when doing DER decoding.

5536 - 800015A0

  • ERR_CANNOT_GET_CERT_ISPB
  • Certificate ISPB read error.
  • SPB module decode (e.g., when decoding GEN msgs that demand auto-update operations) could not retrieve certificate ISPB. It's usually a memory allocation problem when doing DER decoding.

5537 - 800015A1

  • ERR_INVALID_HASH
  • Request sent invalid hash.
  • This usually signals invalid informed hash mode/type or len. Raised in the following scenarios: a) PKCS #10 generation requests; b) ECC sign/verify operations; c) SPB encoding/decoding requests;

5538 - 800015A2

  • ERR_INVALID_SIG_LEN
  • Signature buffer len is too big.
  • Raised in the following scenarios: a) ECC verify operation;

5539 - 800015A3

  • ERR_INVALID_PUBKEY_LEN
  • Public key buffer len is too big.
  • Raised in the following scenarios: a) core RSA public tasks; b) ECC verify operation;

5540 - 800015A4

  • ERR_INVALID_PSKC_XML
  • XML handling error.
  • HSM was not able to manipulate the informed XML (it's probably incomplete/malformed/invalid). Raised in the following scenarios: a) OATH module PSKC importing;

5541 - 800015A5

  • ERR_CANNOT_FIND_PSKC_XML_NODE
  • XML handling error.
  • HSM was not able to manipulate the informed XML (it's probably incomplete/malformed/invalid). Raised in the following scenarios: a) OATH module PSKC importing;

5542 - 800015A6

  • ERR_CANNOT_FIND_PSKC_XML_ATTR
  • XML handling error.
  • HSM was not able to manipulate the informed XML (it's probably incomplete/malformed/invalid). Raised in the following scenarios: a) OATH module PSKC importing;

5543 - 800015A7

  • ERR_INVALID_PSKC_KEY_DERIVATION
  • XML handling error.
  • HSM was not able to use the informed key derivation algorithm. Only PBKDF2 is supported. Raised in the following scenarios: a) OATH module PSKC importing;

5544 - 800015A8

  • ERR_INVALID_PSKC_KEY_DERIVATION_IT
  • XML handling error.
  • HSM was not able to use the informed key derivation iteration counter. Only valid PBKDF2 is supported. Raised in the following scenarios: a) OATH module PSKC importing;

5545 - 800015A9

  • ERR_INVALID_PSKC_KEY_DERIVATION_LEN
  • XML handling error.
  • HSM was not able to use the informed key derivation len. Only valid PBKDF2 is supported. Raised in the following scenarios: a) OATH module PSKC importing;

5546 - 800015AA

  • ERR_INVALID_PSKC_KEY_DERIVATION_SALT_LEN
  • XML handling error.
  • HSM was not able to use the informed key derivation salt len. Only valid PBKDF2 is supported. Raised in the following scenarios: a) OATH module PSKC importing;

5547 - 800015AB

  • ERR_PSKC_KEY_DERIVATION_FAILED
  • PSKC PKCS #5 derivation error.
  • HSM was not able to do key derivation according to PKCS #5. Raised in the following scenarios: a) OATH module PSKC importing;

5548 - 800015AC

  • ERR_INVALID_PSKC_KEY_ALG
  • XML handling error.
  • HSM was not able to use the informed algorithm. Only HOTP and TOTP are supported. Raised in the following scenarios: a) OATH module PSKC importing;

5549 - 800015AD

  • ERR_INVALID_PSKC_KEY_METHOD
  • XML handling error.
  • HSM was not able to use the informed key encryption method. Only AES128-CBC is supported. Raised in the following scenarios: a) OATH module PSKC importing;

5550 - 800015AE

  • ERR_INVALID_OATH_EPOCH
  • OATH date/time handling failure.
  • HSM was not able to use the informed Epoch (currently, no offsets are supported). Raised in the following scenarios: a) OATH module PSKC importing;

5551 - 800015AF

  • ERR_INVALID_OATH_TIMESTEP
  • OATH date/time handling failure.
  • HSM was not able to use the informed Time-Step (currently, only values equal to, or greater than 30 are supported). Raised in the following scenarios: a) OATH module PSKC importing;

5552 - 800015B0

  • ERR_INVALID_OATH_DRIFT
  • OATH date/time handling failure.
  • HSM was not able to use the informed drift (currently, no shifts are supported). Raised in the following scenarios: a) OATH module PSKC importing;

5553 - 800015B1

  • ERR_INVALID_PSKC_SECRET_LEN
  • XML handling error.
  • HSM was not able to use the informed secret len. Only PKCS #5/PBKDF2 with AES128-CBC are supported. Raised in the following scenarios: a) OATH module PSKC importing;

5554 - 800015B2

  • ERR_UNKNOWN_PADDING_TYPE
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5555 - 800015B3

  • ERR_DATA_TOO_LARGE_FOR_MODULUS
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5556 - 800015B4

  • ERR_DATA_GREATER_THAN_MODULUS_LEN
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5557 - 800015B5

  • ERR_PADDING_CHECK_FAILED
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5558 - 800015B6

  • ERR_DATA_TOO_LARGE_FOR_KEY_SIZE
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5559 - 800015B7

  • ERR_DATA_TOO_SMALL_FOR_KEY_SIZE
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5560 - 800015B8

  • ERR_INVALID_TYPE1_PADDING
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5561 - 800015B9

  • ERR_INVALID_TYPE2_PADDING
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5562 - 800015BA

  • ERR_BAD_FIXED_HDR_PADDING
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5563 - 800015BB

  • ERR_MISSING_NULL_PADDING
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5564 - 800015BC

  • ERR_BAD_PAD_BYTE_COUNT
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5565 - 800015BD

  • ERR_DATA_TOO_LARGE_FOR_PADDING
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5566 - 800015BE

5567 - 800015BF

  • ERR_STATIC_BN_CANNOT_EXPAND
  • Operation failed.
  • DEPRECATED. Raised by old firmware. See ERR_OPERATION_FAILED.

5568 - 800015C0

5569 - 800015C1

  • ERR_TOO_MANY_BN_ITERATIONS
  • Operation failed.
  • DEPRECATED. Raised by old firmware. See ERR_OPERATION_FAILED.

5570 - 800015C2

  • ERR_BN_IS_NOT_A_SQUARE
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5571 - 800015C3

5572 - 800015C4

  • ERR_BN_NOT_INITIALIZED
  • Operation failed.
  • DEPRECATED. Raised by old firmware. See ERR_OPERATION_FAILED.

5573 - 800015C5

  • ERR_BN_INVALID_RANGE
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5574 - 800015C6

  • ERR_BN_BAD_RECIPROCAL
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5575 - 800015C7

  • ERR_BN_CALLED_WITH_EVEN_MODULUS
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5576 - 800015C8

  • ERR_BN_INPUT_NOT_REDUCED
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5577 - 800015C9

  • ERR_BN_TOO_MANY_TMP_VARIABLES
  • Operation failed.
  • DEPRECATED. Raised by old firmware. See ERR_OPERATION_FAILED.

5578 - 800015CA

5579 - 800015CB

  • ERR_BN_ENCODING_ERROR
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5580 - 800015CC

  • ERR_INVALID_PUBLIC_EXP
  • Invalid data error.
  • DEPRECATED. Raised by old firmware. See ERR_INVALID_OPERATION.

5581 - 800015CD

  • ERR_INVALID_SPB_HDR_LEN
  • SPB message header 'magic number' error.
  • SPB module decode request detected an invalid message header length. Please, refer to SPB manual for further details.

5582 - 800015CE

  • ERR_INVALID_SPB_HDR_VER
  • Invalid SPB message header version.
  • SPB module decode request detected an unsupported message header version (V1 == 1 or V2 == 2 expected). Please, refer to SPB manual for further details.

5583 - 800015CF

  • ERR_INVALID_SPB_HDR_SPECIAL_TREATMENT
  • Invalid SPB message header special treatment flag.
  • SPB module decode request detected an invalid message header special treatment flag combination (values 0-4, 6, 8, and 10 supported). Please, refer to SPB manual for further details.

5584 - 800015D0

  • ERR_INVALID_SPB_HDR_R0
  • Invalid SPB message header reserved value.
  • SPB module decode request detected an invalid message header reserved value (must be 0). Please, refer to SPB manual for further details.

5585 - 800015D1

  • ERR_INVALID_SPB_HDR_DST_ASYM_ALG
  • Invalid SPB message header certificate algorithm.
  • SPB module decode request detected an invalid message header certificate algorithm (RSA_1024 == 1 or RSA_2048 == 2 expected). Please, refer to SPB manual for further details.

5586 - 800015D2

  • ERR_INVALID_SPB_HDR_DST_SYM_ALG
  • Invalid SPB message header encryption algorithm.
  • SPB module decode request detected an invalid message header encryption algorithm (3DES_168 == 1 expected). Please, refer to SPB manual for further details.

5587 - 800015D3

  • ERR_INVALID_SPB_HDR_SIGN_KEY_TYPE
  • Invalid SPB message header signature algorithm.
  • SPB module decode request detected an invalid message header signature algorithm (RSA_1024 == 1 or RSA_2048 == 2 expected). Please, refer to SPB manual for further details.

5588 - 800015D4

  • ERR_INVALID_SPB_HDR_DST_CA
  • Invalid SPB message header Certificate Authority (CA).
  • See ERR_INVALID_CA for extra details.

5589 - 800015D5

  • ERR_INVALID_SPB_HDR_SIGN_CA
  • Invalid SPB message header Certificate Authority (CA).
  • See ERR_INVALID_CA for extra details.

5590 - 800015D6

  • ERR_INVALID_SIGN_CERT_SN_MISMATCH
  • SPB message header certificate serial number mismatch.
  • See ERR_INVALID_CERT_SN_MISMATCH for extra details.

5591 - 800015D7

  • ERR_INVALID_DST_CERT_SN_MISMATCH
  • SPB message header certificate serial number mismatch.
  • See ERR_INVALID_CERT_SN_MISMATCH for extra details.

5592 - 800015D8

  • ERR_INVALID_SPB_MSG_LEN
  • Invalid SPB message length.
  • SPB module decode request detected an invalid message length (it must be a multiple of a DES block). Please, refer to SPB manual for further details.

5593 - 800015D9

  • ERR_CANNOT_PARSE_JSON
  • JSON parsing error.
  • HSM was not able to decode a JSON stream (it may be malformed/invalid). The storage-layer employs an internal JSON representation to allow flexible and fast operations, like when executing native PKCS #11 tasks. Can be raised in lots of scenarios, specially when manipulating objs (e.g., keys and certificates).

5594 - 800015DA

  • ERR_INVALID_SPB_CHARSET_SIG_OK
  • Invalid SPB message charset, with verified/valid signature.
  • See ERR_INVALID_SPB_CHARSET for extra details.

5595 - 800015DB

  • ERR_JSON_MORE_DATA
  • JSON serialization error.
  • HSM was not able to serialize a JSON stream, cause it exceeds the operational internal limit. See ERR_CANNOT_ALLOC_MEM and ERR_CANNOT_PARSE_JSON for extra details that may apply here. If this error persists, please contact OEM.

5596 - 800015DC

  • ERR_CANNOT_VIRTUALIZE_JSON
  • JSON handling error.
  • HSM was not able to generate a JSON stream. This is usually a memory management issue. See ERR_CANNOT_ALLOC_MEM and ERR_CANNOT_PARSE_JSON for extra details that may apply here. If this error persists, please contact OEM.

5597 - 800015DD

  • ERR_CANNOT_CHANGE_OEM_JSON
  • JSON handling error.
  • Some native PKCS #11 write operation tried to modify a read-only JSON attribute. Check client SDK documentation. See ERR_CANNOT_PARSE_JSON. If this error persists, please contact OEM.

5598 - 800015DE

5599 - 800015DF

  • ERR_INVALID_SPB_CHARSET
  • Invalid SPB message charset.
  • SPB module decode request detected an invalid message character (it must be belong to Basic_Latin or Latin-1_Supplement. Please, refer to DRN-aprovados for further details.

5600 - 800015E0

  • ERR_CANNOT_GET_JSON
  • JSON serialization error.
  • HSM was not able to serialize a JSON stream. This is usually a memory management issue. See ERR_CANNOT_ALLOC_MEM and ERR_CANNOT_PARSE_JSON for extra details that may apply here.

5601 - 800015E1

  • ERR_INVALID_SPB_CHARSET_SIG_ERR
  • Invalid SPB message charset, with invalid signature.
  • See ERR_INVALID_SPB_CHARSET for extra details.

5602 - 800015E2

  • ERR_INVALID_SPB_DOMAIN
  • Invalid SPB domain.
  • SPB domain ids must be composed of no more than 6 alphanumeric characters (letters or numbers).

5603 - 800015E3

  • ERR_CANNOT_GEN_DSA_KEY
  • Storage layer could not create a DSA key.
  • HSM could not create an DSA key cause its crypto material handling failed. This can be a memory allocation issue. In rare scenarios, random number generation may have failed. See ERR_DRBG_CONTINUOUS_TEST for extra details that may apply here. If this error persists, please contact OEM.

5604 - 800015E4

  • ERR_DSA_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5605 - 800015E5

  • ERR_CANNOT_GEN_DH_KEY
  • Storage layer could not create a DH key.
  • HSM could not create an DH key cause its crypto material handling failed. This can be a memory allocation issue. In rare scenarios, random number generation may have failed. See ERR_DRBG_CONTINUOUS_TEST for extra details that may apply here. If this error persists, please contact OEM.

5606 - 800015E6

  • ERR_DH_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • DEPRECATED. Raised by old firmware. See ERR_KEY_CONTINUOUS_TEST.

5699 - 80001643

  • ERR_KEY_CONTINUOUS_TEST
  • Storage layer could not create/open/import a key.
  • HSM detected a consistency problem while doing a runtime test, and refused to let the key be created/used. See ERR_DRBG_CONTINUOUS_TEST for extra details that may apply here. If this error persists, please contact OEM.

5700 - 80001644

  • ERR_SERVER_STARTED
  • An invalid request was sent.
  • The requested operation can't be executed while service is running.

5701 - 80001645

  • ERR_HSM_AUTO_TEST_FAILURE
  • HSM may be operating inconsistently.
  • Auto-testing failures were detected. If restricted mode is active, no operation can take place. In standard mode, operation is allowed (but low-level error conditions can leave the HSM working in an inconsistent state). See ERR_NON_APPROVED_OPERATION.

5702 - 80001646

  • ERR_SERVER_NOT_STARTED
  • An invalid request was sent.
  • The requested operation can't be executed while service isn't running.

5703 - 80001647

  • ERR_UNAPPROVED_TSP_OPERATION
  • Non approved TSP operation refused.
  • Some functionality was rejected because it violates RFC 3161, RFC 5816, and/or some corporate security policy. For example: a) exporting TSP private-keys used to sign timestamps; b) using non TSP private-key to sign timestamps; c) trying to operate while in suspension state;

5704 - 80001648

  • ERR_INVALID_LCRYPTO_R_OPERATION
  • Remote local-crypto-partition operation refused.
  • DEPRECATED. Raised by old firmware.

7000 - 80001B58

  • ERR_DEPRECATED_OBJ_BLOCKED_BY_DS_POLICY
  • Object usage error.
  • Security layer blocked object use cause global remote policy was violated.

7001 - 80001B59

  • ERR_TRUNCATING_DS_LOG
  • Log truncation failed.
  • DEPRECATED. Raised by old firmware.

10000 - 80002710

  • ERR_THROTTLED_VM_SIZE
  • Service memory safe operation threshold reached.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_ALLOC_RES.

10001 - 80002711

  • ERR_THROTTLED_RAM
  • System RAM safe operation threshold reached.
  • DEPRECATED. Raised by old firmware. See ERR_CANNOT_ALLOC_MEM.

11000 - 80002AF8

  • ERR_CANNOT_ALLOC_SOCKET
  • Network descriptor could not be allocated.
  • HSM was not capable of allocating a network socket. This usually signals a descriptor and/or memory leak. See ERR_CANNOT_ALLOC_RES for extra details that may apply here. If this error persists, please contact OEM.

11001 - 80002AF9

  • ERR_CANNOT_ALLOC_MEM
  • Memory allocation failure.
  • HSM was not capable of allocating more memory. This usually signals severe server overload and/or memory leaks. See ERR_CANNOT_ALLOC_RES for extra details that may apply here. If this error persists, please contact OEM.

11002 - 80002AFA

  • ERR_CANNOT_ALLOC_KEY
  • Key memory could not be allocated.
  • HSM was not capable of allocating a key working buffer. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here. If this error persists, please contact OEM.

11003 - 80002AFB

  • ERR_CANNOT_ALLOC_SL_BE_HANDLE
  • Storage layer descriptor could not be allocated.
  • HSM was not capable of allocating a low-level IO handle. See ERR_SL_BE_BUSY for extra details that may apply here.

11004 - 80002AFC

  • ERR_CANNOT_ALLOC_IOM
  • Working memory could not be allocated.
  • HSM was not capable of allocating a working buffer. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11005 - 80002AFD

  • ERR_CANNOT_INIT_DRBG
  • Random number generation error.
  • DRBG subsystem could not initialize, and will refuse to generate any stream of cryptographically strong random numbers. See ERR_CANNOT_GENERATE_RND_DATA and ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11006 - 80002AFE

11007 - 80002AFF

11008 - 80002B00

  • ERR_CANNOT_ALLOC_OBJ_HANDLE
  • Storage layer obj descriptor could not be allocated.
  • HSM was not capable of allocating a low-level obj handle. See ERR_CANNOT_ALLOC_MEM and ERR_CACHE_LAYER_EXHAUSTED for extra details that may apply here.

11009 - 80002B01

11010 - 80002B02

  • ERR_CANNOT_ALLOC_TLS_CTX
  • Encrypted channel descriptor could not be prepared.
  • HSM could not prepare a TLS network socket (used for replication layer communication). This usually signals a memory leak. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11011 - 80002B03

  • ERR_CANNOT_ALLOC_TLS_SOCKET
  • Encrypted channel descriptor could not be allocated.
  • HSM was not capable of allocating a TLS network socket (used for replication layer communication). This usually signals a memory leak. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11012 - 80002B04

  • ERR_CANNOT_SERIALIZE_XML
  • XML DSig generation failure.
  • XML module tried to generate a digital signature according to RFC 3275, but DOM serialization failed. This is usually a memory management issue. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11013 - 80002B05

  • ERR_CANNOT_ALLOC_BN
  • Number (BN) too big to allocate.
  • System can't work with a multiprecision integer. This is usually an input error, but can also be a memory management issue. See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

11014 - 80002B06

  • ERR_CANNOT_ALLOC_JSON
  • JSON handling error.
  • See ERR_CANNOT_ALLOC_MEM for extra details that may apply here.

12001 - 80002EE1

  • ERR_CRYPTOHW_OPEN_FAILURE
  • TAC_ERR_CRYPTOHW_OPEN_FAILURE
  • TAC_ERR_CRYPTOHW_OPEN_FAILURE

12002 - 80002EE2

  • ERR_CRYPTOHW_SETUP_FAILURE
  • TAC_ERR_CRYPTOHW_SETUP_FAILURE
  • TAC_ERR_CRYPTOHW_SETUP_FAILURE

12003 - 80002EE3

  • ERR_CRYPTOHW_READ_FAILURE
  • TAC_ERR_CRYPTOHW_READ_FAILURE
  • TAC_ERR_CRYPTOHW_READ_FAILURE

12004 - 80002EE4

  • ERR_CRYPTOHW_INVALID_CRC
  • TAC_ERR_CRYPTOHW_INVALID_CRC
  • TAC_ERR_CRYPTOHW_INVALID_CRC

12005 - 80002EE5

  • ERR_CRYPTOHW_WRITE_FAILURE
  • TAC_ERR_CRYPTOHW_WRITE_FAILURE
  • TAC_ERR_CRYPTOHW_WRITE_FAILURE

12006 - 80002EE6

  • ERR_CRYPTOHW_UNEXPECTED_MSG
  • TAC_ERR_CRYPTOHW_UNEXPECTED_MSG
  • TAC_ERR_CRYPTOHW_UNEXPECTED_MSG

12007 - 80002EE7

  • ERR_CRYPTOHW_CONNECT_FAILED
  • TAC_ERR_CRYPTOHW_CONNECT_FAILED
  • TAC_ERR_CRYPTOHW_CONNECT_FAILED

12008 - 80002EE8

  • ERR_CRYPTOHW_SEND_FAILED
  • TAC_ERR_CRYPTOHW_SEND_FAILED
  • TAC_ERR_CRYPTOHW_SEND_FAILED

12009 - 80002EE9

  • ERR_CRYPTOHW_RECV_FAILED
  • TAC_ERR_CRYPTOHW_RECV_FAILED
  • TAC_ERR_CRYPTOHW_RECV_FAILED

36000 - 80008CA0

  • ERR_REPLICATION_BUSY
  • Replication layer access failure.
  • The requested operation could not be executed cause replication layer is still updating/writing synchronization data. This is usually a transient problem. Please, try again later.

36001 - 80008CA1

  • ERR_REPLICATION_D_BUSY
  • Replication layer access failure.
  • The requested operation could not be executed. Replication layer has pending synchronization data updates. This is usually a complex issue, that demands OEM intervention.

36002 - 80008CA2

  • ERR_REPLICATION_S_BUSY
  • Replication layer access failure.
  • The requested operation could not be executed cause replication layer is still updating/writing synchronization data. This is usually a transient problem. Please, try again later.

36003 - 80008CA3

  • ERR_REPLICATION_STORAGE_LAYER_BUSY
  • Replication layer access failure.
  • The requested operation could not be executed cause replication layer is still updating/writing synchronization data. This is usually a transient problem. Please, try again later.

36004 - 80008CA4

  • ERR_REPLICATION_SEC_LAYER_BUSY
  • Replication layer access failure.
  • The requested operation could not be executed cause replication layer is still updating/writing synchronization data. This is usually a transient problem. Please, try again later.

36500 - 80008E94

  • ERR_REPLICATION_PEER_NOT_SYNCED
  • Replication layer transaction failure.
  • The requested operation could not be executed. Replication layer detected that one node from the pool is not synchronized. Without a live-sync, any operation that demands storage layer updates will fail, protecting customer base against split-brain problems (when data among peers from the same pool is not exactly mirrored). This usually happens when a new HSM is added to an existing pool, without being properly live-synced to its peers.

37001 - 80009089

  • ERR_REPLICATION_CANNOT_PREPARE_TRANS
  • Replication layer transaction failure.
  • The requested operation was not executed cause replication layer could not setup a distributed transaction. It may or may not be a temporary problem. If this issue persists, please contact OEM.

37002 - 8000908A

  • ERR_REPLICATION_CANNOT_P2P_HANDSHAKE
  • Replication layer network protocol failure.
  • The requested operation could not be executed. There was a network failure involved, or the peers are not setup in a way that allows synchronization to happen between them (HSMs can only replicate if they share the same SVMK and operating mode). It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37003 - 8000908B

  • ERR_REPLICATION_CANNOT_P2P_FIND
  • Replication layer node cache incompleteness.
  • The requested operation could not be executed cause replication layer did not find one involved HSM/node. This is a rare occurrence, and signals an incomplete/invalid network node cache. Check this configuration at local console (shell).

37004 - 8000908C

  • ERR_REPLICATION_CANNOT_P2P_CONNECT
  • Replication layer network connection failure.
  • The requested operation could not be executed. There was a network connection failure, and one the HSM peers could not be reached. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37005 - 8000908D

  • ERR_REPLICATION_CANNOT_P2P_SEND
  • Replication layer network transmission problem.
  • The requested operation could not be executed. There was a network transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37006 - 8000908E

  • ERR_REPLICATION_CANNOT_P2P_RECV
  • Replication layer network transmission problem.
  • The requested operation could not be executed. There was a network transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37007 - 8000908F

  • ERR_REPLICATION_CANNOT_P2P_SEND_ALL
  • Replication layer network transmission problem.
  • The requested operation could not be executed. There was a network transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37008 - 80009090

  • ERR_REPLICATION_CANNOT_P2P_RECV_ALL
  • Replication layer network transmission problem.
  • The requested operation could not be executed. There was a network transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37009 - 80009091

  • ERR_REPLICATION_CANNOT_P2P_SCONNECT
  • Replication layer network connection failure.
  • The requested operation could not be executed. There was a TLS failure involved, or the peers are not setup in a way that allows synchronization to happen between them (HSMs can only replicate if they share the same SVMK and operating mode). It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37010 - 80009092

  • ERR_REPLICATION_CANNOT_P2P_SSEND
  • Replication layer secure network transmission problem.
  • The requested operation could not be executed. There was a TLS transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37011 - 80009093

  • ERR_REPLICATION_CANNOT_P2P_SRECV
  • Replication layer secure network transmission problem.
  • The requested operation could not be executed. There was a TLS transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37012 - 80009094

  • ERR_REPLICATION_CANNOT_P2P_SSEND_ALL
  • Replication layer secure network transmission problem.
  • The requested operation could not be executed. There was a TLS transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37013 - 80009095

  • ERR_REPLICATION_CANNOT_P2P_SRECV_ALL
  • Replication layer secure network transmission problem.
  • The requested operation could not be executed. There was a TLS transfer failure between HSM nodes. It may or may not be a transient problem. See ERR_NET_FAIL regarding network issues.

37014 - 80009096

  • ERR_REPLICATION_CANNOT_P2P_WORK
  • Replication layer network exception.
  • The requested operation could not be executed. There was a network setup failure. It may or may not be a transient problem. If it persists, contact OEM.

37015 - 80009097

  • ERR_REPLICATION_NOT_FOUND
  • Replication layer access failure.
  • Reserved for HSMs doing replication layer synchronization. In rare cases, clients can receive this error, specially when retrieving remote replication information through administrative tools. It should be a transient problem. If it persists, contact OEM.

37016 - 80009098

  • ERR_REPLICATION_ACK_NOT_FOUND
  • Replication layer transaction acknowledgment exception.
  • Reserved for HSMs doing replication layer synchronization. It should be a transient problem. If it persists, contact OEM.

37017 - 80009099

  • ERR_REPLICATION_INVALID_OPERATION
  • Invalid replication request.
  • Operations can be flagged as invalid if one or more parameters are not recognized by the HSM, and/or if they are not valid in the operational context. This error can be the result of bad requests from clients (e.g., with invalid data), IO errors on the server side, or software version mismatches (when HSMs operating on the same pool are setup with different firmware versions). It can be a transient problem. For further assistance, contact OEM.

37018 - 8000909A

  • ERR_REPLICATION_INVALID_EVENT
  • Invalid replication occurrence.
  • Replication layer events can be flagged as invalid if they're not recognized by the HSM, and/or if they are not valid in the operational context (e.g., when clients send node-down-msgs, but server can reach the so-called down peer). In rare occasions, firmware version mismatches can cause this.

37019 - 8000909B

  • ERR_REPLICATION_OPERATION_FAILED
  • Replication layer access failure.
  • Reserved for HSMs doing replication layer synchronization. In rare cases, clients can receive this error, specially when sending remote 'pulsing' requests through administrative tools. It should be a transient problem. If it persists, contact OEM.

37020 - 8000909C

  • ERR_REPLICATION_COMMIT_FAILED
  • Replication layer IO failure.
  • Reserved for HSMs doing replication layer synchronization. In some cases, clients can receive this error, specially when sending 'node-down' msgs. Live-syncs between HSMs can raise this exception. It should be a transient problem. If it persists, contact OEM.

37021 - 8000909D

  • ERR_REPLICATION_ERASE_FAILED
  • Replication layer IO failure.
  • Reserved for HSMs doing replication layer synchronization. In some cases, clients can receive this error, specially when sending node-down-msgs. It should be a transient problem. If it persists, contact OEM.

37022 - 8000909E

  • ERR_REPLICATION_INQUIRE_FAILED
  • Replication layer IO failure.
  • Reserved for HSMs doing replication layer synchronization. It should be a transient problem. If it persists, contact OEM.

37023 - 8000909F

  • ERR_REPLICATION_UPDATE_ACK_FAILED
  • Replication layer IO failure.
  • Reserved for HSMs doing replication layer synchronization. It should be a transient problem. If it persists, contact OEM.

37024 - 800090A0

  • ERR_REPLICATION_DISPATCH_FAILED
  • Replication layer IO failure.
  • Reserved for replication layer core manager. It should be a transient problem. If it persists, contact OEM.

37025 - 800090A1

  • ERR_REPLICATION_CANNOT_SL_BE_TRANSP
  • Replication layer IO failure.
  • The requested operation could not be executed. Reserved for replication layer low-level IO. Administrative operations may raise this error (e.g., when updating node cache). It should be a transient problem. If it persists, contact OEM.

37026 - 800090A2

  • ERR_REPLICATION_CANNOT_PRUNE_LOG
  • Replication layer IO failure.
  • The requested operation could not be executed. Reserved for replication layer low-level IO. It should be a transient problem. If it persists, contact OEM.

37027 - 800090A3

  • ERR_REPLICATION_CANNOT_LOAD_LOG
  • Replication layer transaction log access failure.
  • Reserved for HSMs doing replication layer synchronization. In rare cases, clients can receive this error, specially when retrieving remote replication information through administrative tools. It should be a transient problem. If it persists, contact OEM.

37028 - 800090A4

  • ERR_REPLICATION_CANNOT_WORK
  • Replication layer access failure.
  • Reserved for HSMs doing replication layer synchronization. In some cases, clients can receive this error (specially when sending node-down-msgs, or when retrieving remote replication information through administrative tools). It should be a transient problem. If it persists, contact OEM.

37029 - 800090A5

  • ERR_REPLICATION_CANNOT_VALIDATE_EVENT
  • Replication layer IO failure.
  • The requested operation could not be executed. Reserved for replication layer low-level IO. It should be a transient problem. If it persists, contact OEM.

37030 - 800090A6

  • ERR_REPLICATION_TRANS_MISMATCH
  • Replication layer transaction inconsistency.
  • The requested operation could not be executed. Reserved for replication layer distributed transaction validation. Live-syncs between HSMs can raise this error. It should be a transient problem. If it persists, contact OEM.

37031 - 800090A7

  • ERR_REPLICATION_CANNOT_SYNC_POINT
  • Replication layer transaction error.
  • The requested operation could not be executed. Reserved for replication layer distributed transaction validation. Live-syncs between HSMs can raise this error. It should be a transient problem. If it persists, contact OEM.

37032 - 800090A8

  • ERR_REPLICATION_UNDEFINED_LIVE_SYNC
  • Replication live-sync refused.
  • Live-syncs between HSMs can only happen if the applicant (i.e., the node that requested the sync on local console) didn't execute any operation before. Even the simple act of connecting to the applicant through administrative tools will leave the node in an undefined live-sync state. Restarting the service is enough to bring the HSM back to a defined live-sync state (where it can be synchronized to the pool).

37033 - 800090A9

  • ERR_REPLICATION_CONNECTED_LIVE_SYNC
  • Replication live-sync refused.
  • Live-syncs can't happen if there are users connected to the applicant. Disconnect all clients, and try restarting the service. See ERR_REPLICATION_UNDEFINED_LIVE_SYNC for more details.

37034 - 800090AA

  • ERR_REPLICATION_SELF_LIVE_SYNC
  • Replication live-sync refused.
  • Other peers were not found on network node cache (HSM won't live-sync to itself). Please, check your configuration.

37035 - 800090AB

  • ERR_REPLICATION_OBJ_IN_USE
  • Storage layer could not remove an object.
  • HSM was not capable of erasing an obj (usually a key), cause it's opened.

37036 - 800090AC

  • ERR_REPLICATION_CANNOT_BEGIN_TRANS
  • Replication layer transaction failure.
  • The requested operation was not executed cause replication layer could not start a storage layer transaction. It may or may not be a temporary problem. If this issue persists, please contact OEM.

37037 - 800090AD

  • ERR_REPLICATION_MAX_NODE_COUNT_REACHED
  • Replication layer node cache exhausted.
  • The requested operation could not be executed cause replication layer can't add another HSM/node address to the cache (there's a total limit of 16 machines).

37038 - 800090AE

  • ERR_REPL_CANNOT_PREPARE_LS_TRANS
  • Replication layer transaction failure.
  • Live-sync operation was not executed cause replication layer could not setup a distributed transaction. It may or may not be a temporary problem. If this issue persists, please contact OEM.

37039 - 800090AF

  • ERR_REPL_PART_CANNOT_ADD_LOG
  • Replication layer IO failure.
  • The requested operation could not be executed. Reserved for replication layer low-level IO. It should be a transient problem. If it persists, contact OEM.

37040 - 800090B0

  • ERR_REPL_COOR_CANNOT_ADD_LOG
  • Replication layer IO failure.
  • The requested operation could not be executed. Reserved for replication layer low-level IO. It should be a transient problem. If it persists, contact OEM.

47000 - 8000B798

  • ERR_CANNOT_LOAD_DEPRECATED_LICENSE
  • Storage layer could not read HSM license.
  • HSM could not open/read its license information. This error is usually transient, but can signal severe data corruption (and/or hardware problems). Consult OEM.

47001 - 8000B799

  • ERR_INVALID_DEPRECATED_LICENSE
  • HSM license can't be used.
  • HSM could not enforce its license information. This error is usually transient, but can signal severe data corruption (and/or hardware problems). Consult OEM.

47002 - 8000B79A

  • ERR_DEPRECATED_LICENSE_EXPIRED
  • HSM license expired.
  • HSM enforced its license information, that is expired. Please, consult your dealer.

47003 - 8000B79B

  • ERR_DEPRECATED_LICENSE_BLOCKED
  • HSM license is blocked.
  • HSM enforced its license information, that signals blocking. This may be a transient error. Please, consult your dealer.

57001 - 8000DEA9

  • ERR_CANNOT_FIND_LICENSE
  • Storage layer could not find HSM license.
  • HSM could not find informed license. This is usually a transient error, but can signal severe data corruption (and/or hardware problems) if the license was really installed. Consult OEM.

57002 - 8000DEAA

  • ERR_CANNOT_UNINSTALL_OEM_LICENCE
  • Storage layer can't uninstall OEM license.
  • OEM licenses can only be uninstalled with special support. Consult OEM.

57003 - 8000DEAB

  • ERR_LPACK_VERIFY_FAILED
  • License-package signature check failed.
  • License updates can be made through license-packages (lpacks) uploading. In order to prevent malicious inputs, and/or corrupted data to reach the system, lpacks have their content signed by OEM, and their signatures validated when submitted to the HSM.

57004 - 8000DEAC

  • ERR_CANNOT_PROCESS_LPACK
  • License-package processing failure.
  • License updates can be made through license-packages (lpacks) uploading. State manager module was not able to process such lpack, cause some low-level issue was detected (writing to storage layer, memory allocation error, etc). This is usually a transient error, but can signal severe data corruption (and/or hardware failure). If the problem persists, contact OEM.